@@ -1608,4 +1608,34 @@ (define-public ghc-9.4
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory)))))))
+;;; Bootstrap packages for hadrian, the new GHC build system
+
+(define ghc-bootstrap-for-9.6 ghc-9.4)
+
+(define ghc-js-flot-bootstrap-for-9.6
+ (package
+ (name "ghc-js-flot-bootstrap")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (hackage-uri "js-flot" version))
+ (sha256
+ (base32
+ "0yjyzqh3qzhy5h3nql1fckw0gcfb0f4wj9pm85nafpfqp2kg58hv"))))
+ (build-system haskell-build-system)
+ (arguments (list #:tests? #f
+ #:haskell ghc-bootstrap-for-9.6))
+ (properties '((upstream-name . "js-flot")))
+ (home-page "https://github.com/ndmitchell/js-flot")
+ (synopsis "Obtain minified flot code")
+ (description "This package bundles the minified
+@url{http://www.flotcharts.org/, Flot} code (a jQuery plotting library)
+into a Haskell package, so it can be depended upon by Cabal packages.
+The first three components of the version number match the upstream flot
+version. The package is designed to meet the redistribution
+requirements of downstream users (e.g. Debian).")
+ (license license:expat)))
+
;;; haskell.scm ends here
From: Saku Laesvuori <saku@laesvuori.fi> * gnu/packages/haskell.scm (ghc-js-flot-bootstrap-for-9.6): New variable. Change-Id: Ie01768c263084a3aa38b7120de832913a80fc99a --- gnu/packages/haskell.scm | 30 ++++++++++++++++++++++++++++++ 1 file changed, 30 insertions(+)