@@ -1498,12 +1498,6 @@ (define-public ghc-9.2
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory)))))))
-;; Versions newer than ghc defined below (i.e. the compiler
-;; haskell-build-system uses) should use ghc-next as their name to
-;; ensure ghc (without version specification) and ghc-* packages are
-;; always compatible. See https://issues.guix.gnu.org/issue/47335.
-(define-public ghc ghc-9.2)
-
;; 9.4 is the last version to support the make-based build system,
;; but it boot with 9.2, only 9.0 is supported.
(define ghc-bootstrap-for-9.4 ghc-9.0)
@@ -1567,7 +1561,7 @@ (define-public ghc-9.4
(let ((base ghc-9.2))
(package
(inherit base)
- (name "ghc-next")
+ (name "ghc")
(version "9.4.8")
(source (origin
(method url-fetch)
@@ -2166,7 +2160,7 @@ (define-public ghc-9.6
(let ((base ghc-9.4))
(package
(inherit base)
- (name "ghc-next")
+ (name "ghc")
(version "9.6.4")
(source (origin
(inherit (package-source base))
@@ -2267,4 +2261,10 @@ (define-public ghc-9.6
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory)))))))
+;; Versions newer than ghc defined below (i.e. the compiler
+;; haskell-build-system uses) should use ghc-next as their name to
+;; ensure ghc (without version specification) and ghc-* packages are
+;; always compatible. See https://issues.guix.gnu.org/issue/47335.
+(define-public ghc ghc-9.6)
+
;;; haskell.scm ends here
From: Saku Laesvuori <saku@laesvuori.fi> * gnu/packages/haskell.scm (ghc): Update to ghc-9.6 Change-Id: I40da6cacc4d260902cd66d7d626375038fba4346 --- gnu/packages/haskell.scm | 16 ++++++++-------- 1 file changed, 8 insertions(+), 8 deletions(-)