@@ -1638,6 +1638,27 @@ (define ghc-js-flot-bootstrap-for-9.6
requirements of downstream users (e.g. Debian).")
(license license:expat)))
+(define ghc-base16-bytestring-bootstrap-for-9.6
+ (package
+ (name "ghc-base16-bytestring-bootstrap")
+ (version "1.0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "base16-bytestring" version))
+ (sha256
+ (base32
+ "1167f9jaivnabn6kg2gc421ac9njb67fr4v0adbj3qph7qa92nhx"))))
+ (build-system haskell-build-system)
+ (arguments (list #:tests? #f
+ #:haskell ghc-bootstrap-for-9.6))
+ (properties '((upstream-name . "base16-bytestring")))
+ (home-page "http://github.com/haskell/base16-bytestring")
+ (synopsis "Fast base16 (hex) encoding and decoding for ByteStrings")
+ (description
+ "This package provides a Haskell library for working with base16-encoded
+data quickly and efficiently, using the ByteString type.")
+ (license license:bsd-3)))
+
(define ghc-extra-bootstrap-for-9.6
(package
(name "ghc-extra-bootstrap")
From: Saku Laesvuori <saku@laesvuori.fi> * gnu/packages/haskell.scm (ghc-base16-bytestring-bootstrap-for-9.6): New variable. Change-Id: I7c20bdfd7600fb2bed5de497e02acda74b242fec --- gnu/packages/haskell.scm | 21 +++++++++++++++++++++ 1 file changed, 21 insertions(+)