diff mbox series

[bug#67921,v3,14/24] gnu: Add ghc-nats-bootstrap-for-9.6

Message ID 20241031125127.14080-15-ngraves@ngraves.fr
State New
Headers show
Series GHC update. | expand

Commit Message

Nicolas Graves Oct. 31, 2024, 12:46 p.m. UTC
From: Saku Laesvuori <saku@laesvuori.fi>

* gnu/packages/haskell.scm (ghc-nats-bootstrap-for-9.6): New variable.

Change-Id: I57351e88ba0bc52e7fd5fefc5c3006f63925fd86
---
 gnu/packages/haskell.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6c2fd8bdd5..a7e8cc93ef 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1760,6 +1760,28 @@  (define ghc-random-bootstrap-for-9.6
 library, including the ability to split random number generators.")
     (license license:bsd-3)))
 
+(define ghc-nats-bootstrap-for-9.6
+  (package
+    (name "ghc-nats-bootstrap")
+    (version "1.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "nats" version))
+       (sha256
+        (base32
+         "1v40drmhixck3pz3mdfghamh73l4rp71mzcviipv1y8jhrfxilmr"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "nats")))
+    (arguments `(#:haddock? #f
+                 #:haskell ,ghc-bootstrap-for-9.6))
+    (inputs
+     (list ghc-hashable-bootstrap-for-9.6))
+    (home-page "https://hackage.haskell.org/package/nats")
+    (synopsis "Natural numbers")
+    (description "This library provides the natural numbers for Haskell.")
+    (license license:bsd-3)))
+
 (define ghc-js-dgtable-bootstrap-for-9.6
   (package
     (name "ghc-js-dgtable-bootstrap")