diff mbox series

[bug#73884,v2] gnu: Add swaysome

Message ID 20241025192338.10315-1-luca@lucamatei.com
State New
Headers show
Series [bug#73884,v2] gnu: Add swaysome | expand

Commit Message

Luca Matei Pintilie Oct. 25, 2024, 7:23 p.m. UTC
Signed-off-by: Luca Matei Pintilie <luca@lucamatei.com>
Change-Id: I7e9b43b875cfdf68131b0fcff99721655c5af2d0
---
 gnu/packages/rust-apps.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 3844daa651..245e0216eb 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3269,6 +3269,31 @@  (define-public swayr
 daemon which executes them.")
    (license license:gpl3+)))
 
+(define-public swaysome
+  (package
+    (name "swaysome")
+    (version "2.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "swaysome" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "12rqvjj9d12nm9zppgp4hvfw5l308gn9ljbbgbhi0cglpg11rnjk"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+                       ("rust-clap" ,rust-clap-4)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://gitlab.com/hyask/swaysome")
+    (synopsis
+     "Awesome way to manage your multiple outputs with the sway windows manager")
+    (description
+     "This package provides swaysome provides an awesome way to manage your multiple
+outputs with the sway windows manager.")
+    (license license:expat)))
+
 (define-public tealdeer
   (package
     (name "tealdeer")