diff mbox series

[bug#73523,v3,2/3] gnu: Add pywayland version 0.4.18

Message ID 20241025002059.995836-2-aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#73523,v3,1/3] gnu: Add python-xkbcommon version 1.5.1 | expand

Commit Message

Aaron Covrig Oct. 25, 2024, 12:20 a.m. UTC
From: big bug <bigbookofbug@proton.me>

* gnu/packages/python-xyz (python-pywayland): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5001732d4d..41ed393f67 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@ 
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
 ;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
 ;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 big bug <bigbookofbug@proton.me>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37124,6 +37125,31 @@  (define-public python-wasabi
 toolkit for Python.")
     (license license:expat)))
 
+(define-public python-pywayland
+  (package
+    (name "python-pywayland")
+    (version "0.4.18")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pywayland" version))
+       (sha256
+        (base32 "0cv5aqn23id31mn95q6isn5vcnjcd4dvaqzn52ihbb9sg01dx2jr"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (inputs (list wayland))
+    (propagated-inputs (list python-cffi))
+    (native-inputs (list python-pytest pkg-config))
+    (home-page "https://github.com/flacjacket/pywayland/")
+    (synopsis "Python bindings for the libwayland librar")
+    (description
+     "PyWayland provides a wrapper to the libwayland library using the CFFI
+library to provide access to the Wayland library calls and written in pure
+Python.")
+    (license license:asl2.0)))
+
 (define-public python-srt
   (package
     (name "python-srt")