[bug#73884,v1,04/19] gnu: Add rust-windows-interface-0.57
Commit Message
Change-Id: I1c14a99d4a84181a6585e1686080e9d6cc8981e5
---
gnu/packages/crates-windows.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -2174,6 +2174,28 @@ (define-public rust-windows-interface-0.58
"This package provides the interface macro for the Windows crate.")
(license (list license:expat license:asl2.0))))
+(define-public rust-windows-interface-0.57
+ (package
+ (name "rust-windows-interface")
+ (version "0.57.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows-interface" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19zwlzr0q1z9s692681yb5w2lhvwcyx4v95s25hfdkd3isry9gi9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "The interface macro for the windows crate")
+ (description
+ "This package provides The interface macro for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-interface-0.52
(package
(inherit rust-windows-interface-0.58)