diff mbox series

[bug#67902,v5,37/54] gnu: Add php-sebastian-comparator.

Message ID 20241017230627.22689-37-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v5,01/54] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 17, 2024, 11:06 p.m. UTC
* gnu/packages/php-bootstrap.scm (php-sebastian-comparator): New variable.
---
 gnu/packages/php-bootstrap.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-bootstrap.scm b/gnu/packages/php-bootstrap.scm
index 1fabfaf908..8c6a630737 100644
--- a/gnu/packages/php-bootstrap.scm
+++ b/gnu/packages/php-bootstrap.scm
@@ -892,3 +892,27 @@  (define-public php-sebastian-code-unit-reverse-lookup
 method a line of code belongs to in PHP.")
     (home-page "https://github.com/sebastianbergmann/code-unit-reverse-lookup")
     (license license:bsd-3)))
+
+(define-public php-sebastian-comparator
+  (package
+    (name "php-sebastian-comparator")
+    (version "4.0.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/comparator")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00manwzfmsk8vkvra63mbpimkhr8sq9qi1dm3rdkspizy4gg0idl"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-sebastian-exporter php-sebastian-diff))
+    (synopsis "PHP value comparison")
+    (description "This package provides the functionality to compare PHP values
+for equality.")
+    (home-page "https://github.com/sebastianbergmann/comparator")
+    (license license:bsd-3)))