diff mbox series

[bug#67902,v5,28/54] gnu: Add php-phpunit-php-token-stream.

Message ID 20241017230627.22689-28-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v5,01/54] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 17, 2024, 11:05 p.m. UTC
* gnu/packages/php-bootstrap.scm (php-phpunit-php-token-stream): New variable.
---
 gnu/packages/php-bootstrap.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-bootstrap.scm b/gnu/packages/php-bootstrap.scm
index 7d53989dca..497955335e 100644
--- a/gnu/packages/php-bootstrap.scm
+++ b/gnu/packages/php-bootstrap.scm
@@ -704,3 +704,25 @@  (define-public php-phpunit-php-text-template
     (description "This package contains a library for a simple templating engine.")
     (home-page "https://github.com/sebastianbergmann/php-text-template/")
     (license license:bsd-3)))
+
+(define-public php-phpunit-php-token-stream
+  (package
+    (name "php-phpunit-php-token-stream")
+    (version "4.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/php-token-stream")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17pyrfxvjld57i43wanfk84d8x327lwmn1avk6hbwapn4bxic0lv"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (home-page "https://github.com/sebastianbergmann/php-token-stream")
+    (synopsis "Wrapper around PHP's tokenizer extension")
+    (description "This library provides a wrapper around PHP's tokenizer
+extension.")
+    (license license:bsd-3)))