diff mbox series

[bug#73699,v2] gnu: nzbget: Update to 24.3. [security fixes]

Message ID 20241016051922.14328-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#73699,v2] gnu: nzbget: Update to 24.3. [security fixes] | expand

Commit Message

Nicolas Graves Oct. 16, 2024, 5:19 a.m. UTC
This fixes CVE-2023-49102.

* gnu/packages/networking.scm (nzbget): Update to 24.3.
[source]: Switch to git-fetch.
[build-system]: Switch to cmake-build-system.
[arguments]<configure-flags>: Update field.
[inputs]: Add boost, openssl.
[native-inputs]: Remove pkg-config, add which.
---
 gnu/packages/networking.scm | 27 +++++++++++----------------
 1 file changed, 11 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f209c1e27c..79d3859eb1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2843,26 +2843,21 @@  (define-public nethogs
 (define-public nzbget
   (package
     (name "nzbget")
-    (version "21.1")
+    (version "24.3")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/nzbget/nzbget/releases"
-                           "/download/v" version
-                           "/nzbget-" version "-src.tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nzbgetcom/nzbget")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "09900x1k0yf4yi2cc0k093advvadyhrkm8rnd8nszhhdp2zc33sf"))))
+        (base32 "13hakpkxqvqfjhk679l088209f54j7mqi3ifi820lyz6b1nvvj0r"))))
+    (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags
-       (list
-        (string-append "--with-libcurses-includes="
-                       (assoc-ref %build-inputs "ncurses") "/include")
-        (string-append "--with-libcurses-libraries="
-                       (assoc-ref %build-inputs "ncurses") "/lib")
-        (string-append "--with-tlslib=GnuTLS"))))
-    (build-system gnu-build-system)
-    (inputs (list gnutls libxml2 ncurses zlib))
-    (native-inputs (list pkg-config))
+     (list #:configure-flags '(list "-DENABLE_TESTS=1")))
+    (inputs (list boost gnutls libxml2 ncurses openssl zlib))
+    (native-inputs (list which))
     (home-page "https://github.com/nzbget/nzbget")
     (synopsis "Usenet binary file downloader")
     (description