diff mbox series

[bug#73822] gnu: emacs-xyz: add emacs-catppuccin-theme

Message ID 20241015175053.32137-1-bigbookofbug@proton.me
State New
Headers show
Series [bug#73822] gnu: emacs-xyz: add emacs-catppuccin-theme | expand

Commit Message

guix-patches--- via Oct. 15, 2024, 5:51 p.m. UTC
From: emma thompson <bigbookofbug@proton.me>

small addition to emacs-xyz to add the catppuccin theme

---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 377359315fbb0e1414354910ba3a14c145fdc519

Comments

Nicolas Goaziou Oct. 24, 2024, 1:15 p.m. UTC | #1
Hello,

> small addition to emacs-xyz to add the catppuccin theme

I added a proper commit message, tweaked a bit the patch and applied it. Thanks!

> +(define-public emacs-catppuccin-theme
> +  (package
> +   (name "emacs-catppuccin-theme")
> +   (version "20240829.2151")

I used version from upstream instead.

> +   (source
> +    (origin
> +     (method git-fetch)
> +     (uri (git-reference
> +	   (url "https://github.com/catppuccin/emacs.git")

I removed the ".git" suffix.

> +	   (commit "3e4e534a60d72851feb6709be4afe4acc3374c87")))

I let-bound this in a variable around the package definition.

> +     (file-name (git-file-name name version))
> +     (sha256
> +      (base32 "1fj93np7x8b2hvhcryb61ryir49pgy4n8bciph2s43rczz6z1pii"))))
> +   (build-system emacs-build-system)
> +   (home-page "https://github.com/catppuccin/emacs")
> +   (synopsis "Catppuccin for Emacs - Soothing pastel theme for Emacs")
> +   (description
> +    "Soothing pastel theme for Emacs @code{catppuccin-theme.el} provides the theme @code{catppuccin}, a port of the Catppuccin colors to Emacs.  To select a palette and enable the theme, evaluate: @code{(setq catppuccin-flavor frappe)} ; or latte, macchiato, or mocha (load-theme catppuccin t) For more information visit <https://catppuccin.com>.")
> +   (license license:expat)))

I tweaked the description and the synopsis according to project's page.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0be1ac83bc..9864d9f06b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -146,6 +146,7 @@ 
 ;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
+;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
 
 ;;;
 ;;; This file is part of GNU Guix.
@@ -2167,6 +2168,26 @@  (define-public emacs-acme-theme
 inspired by Plan 9 Acme and the Sam text editor.")
       (license license:gpl3+))))
 
+(define-public emacs-catppuccin-theme
+  (package
+   (name "emacs-catppuccin-theme")
+   (version "20240829.2151")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+	   (url "https://github.com/catppuccin/emacs.git")
+	   (commit "3e4e534a60d72851feb6709be4afe4acc3374c87")))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32 "1fj93np7x8b2hvhcryb61ryir49pgy4n8bciph2s43rczz6z1pii"))))
+   (build-system emacs-build-system)
+   (home-page "https://github.com/catppuccin/emacs")
+   (synopsis "Catppuccin for Emacs - Soothing pastel theme for Emacs")
+   (description
+    "Soothing pastel theme for Emacs @code{catppuccin-theme.el} provides the theme @code{catppuccin}, a port of the Catppuccin colors to Emacs.  To select a palette and enable the theme, evaluate: @code{(setq catppuccin-flavor frappe)} ; or latte, macchiato, or mocha (load-theme catppuccin t) For more information visit <https://catppuccin.com>.")
+   (license license:expat)))
+
 (define-public emacs-theme-magic
   ;; No tagged release upstream, but the commit below correspond to the 0.2.3
   ;; release.