diff mbox series

[bug#67902,v4,85/98] gnu: Add php-symfony-translation-contracts.

Message ID 20241007214530.4420-85-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v4,01/98] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 7, 2024, 9:44 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-translation-contracts): New variable.

Change-Id: I36e2c9e50ce2af4d4db531a5a6522ffd6c62990f
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 6603bf828a..8bec5088e1 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2282,3 +2282,23 @@  (define-public php-symfony-string
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-translation-contracts
+  (package
+    (name "php-symfony-translation-contracts")
+    (version "3.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/translation-contracts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0jx7pj30qb94hb8qnav8dp3aif3j0mh66km76dpzj44hz77qnq7l"))))
+    (build-system composer-build-system)
+    (synopsis "PHP translation abstractions")
+    (description "This package provides generic abstractions related to
+translation.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+