diff mbox series

[bug#67902,v4,66/98] gnu: Add php-symfony-filesystem.

Message ID 20241007214530.4420-66-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v4,01/98] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 7, 2024, 9:44 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-filesystem): New variable.

Change-Id: I783fe197168f6dc755de2444ecc16fa9de8f7077
---
 gnu/packages/php-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 132f4eda28..8e1269b65b 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1724,3 +1724,29 @@  (define-public php-symfony-expression-language
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-filesystem
+  (package
+    (name "php-symfony-filesystem")
+    (version "6.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/filesystem")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0m0kza9lz6wh707mzpc0pascwvmxnlmwgpl55w8zpmbs9a2jjsik"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--exclude-group" "network")))
+    (inputs
+     (list php-symfony-polyfill-ctype php-symfony-polyfill-mbstring))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Basic PHP utilities for the filesystem")
+    (description "This package provides basic utilities for the filesystem in
+the Symfony PHP framework.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+