diff mbox series

[bug#67902,v4,56/98] gnu: Add php-cache-integration-tests.

Message ID 20241007214530.4420-56-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v4,01/98] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 7, 2024, 9:44 p.m. UTC
* gnu/packages/php-xyz.scm (php-cache-integration-tests): New variable.

Change-Id: I561d088a95cdcb8629a7e6cab9503be7cf658492
---
 gnu/packages/php-xyz.scm | 42 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index c0342817da..2a03fd6ee4 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1393,3 +1393,45 @@  (define-public php-symfony-cache
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-cache-integration-tests
+  (package
+    (name "php-cache-integration-tests")
+    (version "0.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/php-cache/integration-tests")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0i079z0jmcji4kn9mcxdv2093ypcd6albwkhhkiv39py31bjdpgg"))))
+    (build-system composer-build-system)
+    (arguments
+     (list
+      #:test-flags ''("--testsuite" "Symfony")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'fix-tests
+            (lambda _
+              ;; Adapt phpunit config to Guix context.
+              (substitute* "phpunit.xml.dist"
+                (("\\./vendor/symfony/cache")
+                 (string-append
+                  #$(this-package-native-input "php-symfony-cache")
+                  "/share/web/symfony/cache"))))))))
+    (inputs
+     (list php-psr-cache php-cache-tag-interop))
+    (native-inputs
+     (list php-phpunit-phpunit
+           (package/inherit php-symfony-cache
+             (arguments '(#:tests? #f))
+             (native-inputs '()))
+           php-symfony-filesystem
+           php-symfony-phpunit-bridge))
+    (synopsis "PHP integration tests")
+    (description "This package provides PHP integration tests for PSR-6 and
+PSR-16 cache implementations.")
+    (home-page "https://github.com/php-cache/integration-tests")
+    (license license:expat)))
+