diff mbox series

[bug#67902,v4,41/98] gnu: Add php-sebastian-code-unit-reverse-lookup.

Message ID 20241007214530.4420-41-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v4,01/98] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 7, 2024, 9:44 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-code-unit-reverse-lookup): New variable.

Change-Id: Ie958f6e6d8b5b56ba0b99df8bd457e50ebc549f1
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index cc0029bf48..563b365534 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1018,3 +1018,25 @@  (define-public php-sebastian-code-unit
     (home-page "https://github.com/sebastianbergmann/code-unit")
     (license license:bsd-3)))
 
+(define-public php-sebastian-code-unit-reverse-lookup
+  (package
+    (name "php-sebastian-code-unit-reverse-lookup")
+    (version "2.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/code-unit-reverse-lookup")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zb5lwi46fgarrlbbbxp93md7wfwaxlrmrzvmrmxfqjmxjncpyp0"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Look up function name from location")
+    (description "This package provides a facility to look up which function or
+method a line of code belongs to in PHP.")
+    (home-page "https://github.com/sebastianbergmann/code-unit-reverse-lookup")
+    (license license:bsd-3)))
+