diff mbox series

[bug#67902,v4,40/98] gnu: Add php-sebastian-code-unit.

Message ID 20241007214530.4420-40-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v4,01/98] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 7, 2024, 9:44 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-code-unit): New variable.

Change-Id: Ifd09120cd9bf772706f329623ebf186248267a60
---
 gnu/packages/php-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index fe0db2d8f8..cc0029bf48 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -994,3 +994,27 @@  (define-public php-sebastian-cli-parser
     (home-page "https://github.com/sebastianbergmann/cli-parser")
     (license license:bsd-3)))
 
+(define-public php-sebastian-code-unit
+  (package
+    (name "php-sebastian-code-unit")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/code-unit")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1k259by6jyhzl5qbnamh7270r2jgiw4bjxiy9hc2j8g9gv7ddp10"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--bootstrap" "vendor/autoload.php")))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "PHP collection of value objects for code units")
+    (description "This package contains a collection of value objects that
+represent the PHP code units.")
+    (home-page "https://github.com/sebastianbergmann/code-unit")
+    (license license:bsd-3)))
+