diff mbox series

[bug#67902,v3,82/96] gnu: Add php-symfony-service-contracts.

Message ID 20241007000046.25625-82-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 7, 2024, midnight UTC
* gnu/packages/php-xyz.scm (php-symfony-service-contracts): New variable.

Change-Id: I6e3a8f5cf17e3a71a362a97373cd77bf08781e87
---
 gnu/packages/php-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index aa94d1350b..982de29656 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2202,3 +2202,29 @@  (define-public php-symfony-polyfill-uuid
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-service-contracts
+  (package
+    (name "php-symfony-service-contracts")
+    (version "3.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/service-contracts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "01ilvij609w7mlrif68fc5vs3dw69pmwyci0gp8nh0wljbp9fw5c"))))
+    (build-system composer-build-system)
+    (arguments
+     `(#:test-flags '("--bootstrap" "vendor/autoload.php" "Test")))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-psr-container))
+    (synopsis "PHP abstractions related to writing services")
+    (description "This package provides generic abstractions related to
+writing PHP services.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+