diff mbox series

[bug#67902,v3,07/96] gnu: Add php-doctrine-deprecations.

Message ID 20241007000046.25625-7-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 6, 2024, 11:59 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-deprecations): New variable.

Change-Id: Id91e6a41c2f0d1f97f46f316c1f1152c8931d3ca
---
 gnu/packages/php-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index cfff0d2b1a..017ff751eb 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -135,3 +135,27 @@  (define-public php-doctrine-common
     (home-page "https://www.doctrine-project.org/projects/common")
     (license license:expat)))
 
+(define-public php-doctrine-deprecations
+  (package
+    (name "php-doctrine-deprecations")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/deprecations")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15xq18cl1ws37ansc8h1chbjgybvljxsjgwlp8w3ia5zffwxhrdd"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-doctrine-lexer php-psr-cache))
+    (native-inputs
+     (list php-phpunit-phpunit php-psr-log))
+    (synopsis "Thin library around PHP deprecation strategies")
+    (description "This package provides a layer on top of PHP deprecations
+strategies, with no side-effects by default and customization options.")
+    (home-page "https://github.com/doctrine/deprecations")
+    (license license:expat)))
+