diff mbox series

[bug#67902,v3,04/96] gnu: Add php-cache-tag-interop.

Message ID 20241007000046.25625-4-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 6, 2024, 11:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-cache-tag-interop): New variable.

Change-Id: I6d43ace6b911f22c91964925e807e7685cedced8
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index f1edbbeda9..63e9f05937 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -59,3 +59,25 @@  (define-public composer-classloader
 build its autoloading feature.  This package is used by the composer-build-system
 to build its own store-aware autoloading feature.")
     (license license:expat)))
+
+(define-public php-cache-tag-interop
+  (package
+    (name "php-cache-tag-interop")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/php-cache/tag-interop")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08x7sqxhkwni0arrl68xb2fxd2qjwdkxlxmjq7j3q2ic2qbl8iif"))))
+    (build-system composer-build-system)
+    (inputs (list php-psr-cache))
+    (synopsis "PHP framework for tags")
+    (description "This package provides a PHP framework interoperable
+interfaces for tags.")
+    (home-page "https://www.php-cache.com/en/latest/")
+    (license license:expat)))
+