diff mbox series

[bug#67902,v3,39/96] gnu: Add php-sebastian-cli-parser.

Message ID 20241007000046.25625-39-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 6, 2024, 11:59 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-cli-parser): New variable.

Change-Id: I5b03444eccee5ab2719e39cd0b231fbf632c4428
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 6e55118502..fe0db2d8f8 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -972,3 +972,25 @@  (define-public php-psr-simple-cache
     (home-page "https://github.com/php-fig/simple-cache")
     (license license:expat)))
 
+(define-public php-sebastian-cli-parser
+  (package
+    (name "php-sebastian-cli-parser")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/cli-parser")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08fhain1fwhnhvv0546pszm907g56gqi37pn39dlq1rs6vxsnqd7"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Parse CLI options in PHP")
+    (description "This package provides a PHP library for parsing command-line
+options.")
+    (home-page "https://github.com/sebastianbergmann/cli-parser")
+    (license license:bsd-3)))
+