diff mbox series

[bug#67902,v3,37/96] gnu: Add php-psr-event-dispatcher.

Message ID 20241007000046.25625-37-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 6, 2024, 11:59 p.m. UTC
* gnu/packages/php-xyz.scm (php-psr-event-dispatcher): New variable.

Change-Id: I62db3ea0f3a1429a6bd25c843738b022f3909177
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index b3d265f25b..fbf6251bca 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -932,3 +932,23 @@  (define-public php-psr-container
     (home-page "https://github.com/php-fig/container")
     (license license:expat)))
 
+(define-public php-psr-event-dispatcher
+  (package
+    (name "php-psr-event-dispatcher")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/php-fig/event-dispatcher")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1rxjscznzihbpgngwci61ji8qy5c623qmpy9zpqbj0f5vv8l99kp"))))
+    (build-system composer-build-system)
+    (synopsis "PHP interfaces for event handling")
+    (description "This package provides PHP standard interfaces for event
+handling.")
+    (home-page "https://github.com/php-fig/event-dispatcher")
+    (license license:expat)))
+