diff mbox series

[bug#67902,v3,34/96] gnu: Add php-psr-cache.

Message ID 20241007000046.25625-34-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 6, 2024, 11:59 p.m. UTC
* gnu/packages/php-xyz.scm (php-psr-cache): New variable.

Change-Id: I189f4338cb0c0538c239c39743f10440490852e7
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index f081474934..3d3bf7a113 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -876,3 +876,23 @@  (define-public php-psr-log
     (home-page "https://github.com/php-fig/log")
     (license license:expat)))
 
+(define-public php-psr-cache
+  (package
+    (name "php-psr-cache")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/php-fig/cache")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17z58lcndi97s2lxivv9pcr9yqvrzvrhinwvr2xh4g310wc6pcal"))))
+    (build-system composer-build-system)
+    (synopsis "Cache libraries in PHP")
+    (description
+     "This package provides a common interface for caching PHP libraries.")
+    (home-page "https://github.com/php-fig/cache")
+    (license license:expat)))
+