diff mbox series

[bug#67902,v3,24/96] gnu: Add php-phpspec-prophecy.

Message ID 20241007000046.25625-24-ngraves@ngraves.fr
State New
Headers show
Series [bug#67902,v3,01/96] gnu: Add abnfgen. | expand

Commit Message

Nicolas Graves Oct. 6, 2024, 11:59 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpspec-prophecy): New variable.

Change-Id: Iaeb9800ce9c0881ef161310e72897008679a4545
---
 gnu/packages/php-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 5a9598a74a..9822bba3de 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -612,3 +612,30 @@  (define-public php-phpdocumentor-type-resolver
     (home-page "http://www.phpdoc.org")
     (license license:expat)))
 
+(define-public php-phpspec-prophecy
+  (package
+    (name "php-phpspec-prophecy")
+    (version "1.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/phpspec/prophecy")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1hl6n7y0f68hlsw174izqjph2y7f195dggr4n8sfzffw3iqya0w5"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-sebastian-recursion-context
+           php-doctrine-instantiator
+           php-sebastian-comparator
+           php-phpdocumentor-reflection-docblock))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Mocking framework for PHP 5.3+")
+    (description "This package contains a mocking framework for testing PHP
+5.3+ projects.")
+    (home-page "https://github.com/phpspec/prophecy")
+    (license license:expat)))
+