diff mbox series

[bug#73643,1/2] gnu: librewolf: Fix broken context menu.

Message ID 20241005161911.24298-1-ian@retrospec.tv
State New
Headers show
Series Fix LibreWolf context menu & livestreaming | expand

Commit Message

Ian Eure Oct. 5, 2024, 4:19 p.m. UTC
This patch fixes a reported bug where context (right-click) menus contain many
duplicate and incorrect entries.

* gnu/packages/librewolf.scm (librewolf): Include genai browser component.

Change-Id: I288545ce80b9a7e854edfc26a7ffe43433303458
---
 gnu/packages/librewolf.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 6fd0aa51f1..32b6d13d54 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -212,7 +212,7 @@  (define rust-librewolf rust) ; 1.75 is the default in Guix, 1.65 is the minimum.
 ;; Update this id with every update to its release date.
 ;; It's used for cache validation and therefore can lead to strange bugs.
 ;; ex: date '+%Y%m%d%H%M%S'
-(define %librewolf-build-id "20240922110507")
+(define %librewolf-build-id "20241003201141")
 
 (define-public librewolf
   (package
@@ -324,9 +324,6 @@  (define (write-setting key value)
                             libavcodec)))))
                    (add-after 'unpack 'neuter-genai
                      (lambda* _
-                       ;; Don't compile the code in.
-                       (substitute* "browser/components/moz.build"
-                         (("\"genai\",") ""))
                        ;; Lock the preferences so they can't be enabled.
                        (substitute* "lw/librewolf.cfg"
                          (("defaultPref\\(\"browser\\.ml\\.")