diff mbox series

[bug#73450] Update openfortivpn to 1.22.1

Message ID 20240924134254.24669-2-ikbenrickhuyzer@gmail.com
State New
Headers show
Series [bug#73450] Update openfortivpn to 1.22.1 | expand

Commit Message

Rick Huijzer Sept. 24, 2024, 1:42 p.m. UTC
Works and builds on multiple amd64 machines
---
 gnu/packages/vpn.scm | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

Comments

Rick Huijzer Sept. 26, 2024, 9:27 a.m. UTC | #1
I will create a revised path with a newer ppp, as ppp 2.5.0 included in
guix works fine now.

See https://github.com/adrienverge/openfortivpn/pull/1148
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 0f7300ff51..e8ac94d768 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -840,26 +840,26 @@  (define-public openconnect-sso
 (define-public openfortivpn
   (package
     (name "openfortivpn")
-    (version "1.17.3")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/adrienverge/openfortivpn")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0an58f0qcyxdx3d5zb5m8vi45a0251b950b5lh16572n8z2g6s2l"))))
+    (version "1.22.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/adrienverge/openfortivpn")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0lapfy03b0cafn2mmym72jyidhr53d2ndxhqxzp64hvmramvh50n"))))
     (build-system gnu-build-system)
-    (native-inputs
-     (list autoconf automake pkg-config))
+    (native-inputs (list autoconf automake pkg-config))
     (inputs
      ;; ppp < 2.5.0 is required due to
      ;; <https://github.com/adrienverge/openfortivpn/pull/1148>.
      (list openssl ppp-2.4.9))
     (home-page "https://github.com/adrienverge/openfortivpn")
     (synopsis "Client for PPP+SSL VPN tunnel services")
-    (description "Openfortivpn is a client for PPP+SSL VPN tunnel services.  It
+    (description
+     "Openfortivpn is a client for PPP+SSL VPN tunnel services.  It
 spawns a pppd process and operates the communication between the gateway and
 this process.  It is compatible with Fortinet VPNs.")
     (license license:gpl3+)))