diff mbox series

[bug#73345] gnu: python-gphoto2: Update to 2.5.0

Message ID 20240919010318.1428883-1-aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#73345] gnu: python-gphoto2: Update to 2.5.0 | expand

Commit Message

Aaron Covrig Sept. 19, 2024, 1:03 a.m. UTC
* gnu/packages/python-xyz.scm (python-gphoto2): Update to 2.5.0
---
 gnu/packages/python-xyz.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)


base-commit: 1b6ce1796abdf497f61f426d61339318f4f4f23d
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d402d4f94..0f2985fdcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2284,21 +2284,20 @@  (define-public python-glymur
 (define-public python-gphoto2
   (package
     (name "python-gphoto2")
-    (version "2.2.1")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "gphoto2" version))
-              (sha256
-               (base32
-                "118zm25c8mlajfl0pzssnwz4b8lamj9dgymla9rn4nla7l244a0r"))))
+    (version "2.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gphoto2" version))
+       (sha256
+        (base32 "104yb4g427rqjkaw3i0w30x3sssvmpna802nabjclzq688y7ml4p"))))
     (build-system python-build-system)
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list libgphoto2))
+    (native-inputs (list pkg-config))
+    (inputs (list libgphoto2))
     (home-page "https://github.com/jim-easterbrook/python-gphoto2")
     (synopsis "Python interface to libgphoto2")
-    (description "@code{python-gphoto2} is a comprehensive Python interface
+    (description
+     "@code{python-gphoto2} is a comprehensive Python interface
 (or binding) to @code{libgphoto2}.  It is built using @code{SWIG} to
 automatically generate the interface code.")
     (license license:gpl3+)))