diff mbox series

[bug#73266,9/9] gnu: Add python-spacy-curated-transformers.

Message ID 20240915085720.13323-9-ngraves@ngraves.fr
State New
Headers show
Series [bug#73266,1/9] gnu: Add python-azure-storage-file-datalake. | expand

Commit Message

Nicolas Graves Sept. 15, 2024, 8:57 a.m. UTC
* gnu/packages/machine-learning.scm (python-spacy-curated-transformers): New variable.

Change-Id: Id4b67b2ea2de4745831c3536124304860e9764d8
---
 gnu/packages/machine-learning.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e80412ed41..3afc224e7c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1292,6 +1292,37 @@  (define-public python-sentence-transformers
 models, to achieve maximal performance on your specific task.")
     (license license:asl2.0)))
 
+(define-public python-spacy-curated-transformers
+  (package
+    (name "python-spacy-curated-transformers")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "spacy-curated-transformers" version))
+       (sha256
+        (base32 "1hsqaai666yy9xzj14azli0hgipdkkc5x7xwszh58ndvxsij3dq3"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #f))  ; Missing python-cupy dependency
+    (propagated-inputs (list python-curated-tokenizers
+                             python-curated-transformers
+                             python-cutlery
+                             python-fsspec
+                             python-pytorch
+                             python-spacy
+                             python-thinc))
+    (home-page "https://github.com/explosion/spacy-curated-transformers")
+    (synopsis "Curated transformer models for spaCy pipelines")
+    (description "This package provides transformer models for @code{spaCy}
+pipelines.  It allows you to use pretrained models based on one of the
+following architectures to power your spaCy pipeline: ALBERT, BERT, CamemBERT,
+RoBERTa, XLM-RoBERTa.  It provides all the features supported by
+spacy-transformers such as support for Hugging Face Hub, multi-task learning,
+the extensible config system and out-of-the-box serialization, as well as deep
+integration into spaCy, which lays the groundwork for deployment-focused
+features such as distillation and quantization.")
+    (license license:expat)))
+
 (define-public python-spacy-legacy
   (package
     (name "python-spacy-legacy")