diff mbox series

[bug#73266,5/9] gnu: python-spacy: Update to 3.7.5.

Message ID 20240915085720.13323-5-ngraves@ngraves.fr
State New
Headers show
Series [bug#73266,1/9] gnu: Add python-azure-storage-file-datalake. | expand

Commit Message

Nicolas Graves Sept. 15, 2024, 8:57 a.m. UTC
* gnu/packages/machine-learning.scm (python-spacy): Update to 3.7.5.
[arguments]<#:test-flags>: Ignore test_pass_doc_to_pipeline.
[propagated-inputs]: Remove python-pathy, python-smart-open,
python-typing-extensions. Add python-weasel.

Change-Id: Ieae58f004d06323990e80859e3c4dce2166c447c
---
 gnu/packages/machine-learning.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 4b834a847f..008bf2060a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1336,13 +1336,13 @@  (define-public python-spacy-loggers
 (define-public python-spacy
   (package
     (name "python-spacy")
-    (version "3.5.3")
+    (version "3.7.5")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "spacy" version))
               (sha256
                (base32
-                "13141hc966d8nxbnlwj01vhndgq0rq4nmii3qkb3hrap45kiv5rm"))))
+                "1lrd7k7hizygqldpln4aham6kprbyaj7z7pfd5dabixcyb5wcj56"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -1356,7 +1356,9 @@  (define-public python-spacy
               ;; This tries to run the application with typer, which fails
               ;; with an unspecified error, possibly because the build
               ;; container doesn't have /bin/sh.
-              " and not test_project_assets"))
+              " and not test_project_assets"
+              ;; Fails with DeprecationWarning
+              " and not test_pass_doc_to_pipeline"))
       #:phases
       '(modify-phases %standard-phases
          (add-after 'build 'build-ext
@@ -1370,20 +1372,18 @@  (define-public python-spacy
                              python-murmurhash
                              python-numpy
                              python-packaging
-                             python-pathy
                              python-preshed
                              python-pydantic
                              python-requests
                              python-setuptools
-                             python-smart-open
                              python-spacy-legacy
                              python-spacy-loggers
                              python-srsly
                              python-thinc
                              python-tqdm
                              python-typer
-                             python-typing-extensions
-                             python-wasabi))
+                             python-wasabi
+                             python-weasel))
     (native-inputs
      (list python-cython python-pytest python-mock))
     (home-page "https://spacy.io")