diff mbox series

[bug#73266,4/9] gnu: python-thinc: Update to 8.2.2.

Message ID 20240915085720.13323-4-ngraves@ngraves.fr
State New
Headers show
Series [bug#73266,1/9] gnu: Add python-azure-storage-file-datalake. | expand

Commit Message

Nicolas Graves Sept. 15, 2024, 8:57 a.m. UTC
* gnu/packages/machine-learning.scm (python-thinc): Update to 8.2.2.
[propagated-inputs]: Remove python-contextvars, python-dataclasses,
python-typing-extensions.

Change-Id: Ic9176f75b7a7fe075a72c7b6607bc1a1b39294f4
---
 gnu/packages/machine-learning.scm | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 107954577b..4b834a847f 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2093,13 +2093,13 @@  (define-public python-mord
 (define-public python-thinc
   (package
     (name "python-thinc")
-    (version "8.1.10")
+    (version "8.2.2")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "thinc" version))
               (sha256
                (base32
-                "14drmwa2sh8fqszv1fm2jl4lky1j5yrbkjv89bl49q07vbblhjkc"))))
+                "11qmdpw4r7qm1l5p8iws8jf33az1hac7zxki38j9a3rccx2bk1bf"))))
     (build-system pyproject-build-system)
     (arguments
      '(#:phases
@@ -2111,16 +2111,13 @@  (define-public python-thinc
     (propagated-inputs (list python-blis-for-thinc
                              python-catalogue
                              python-confection
-                             python-contextvars
                              python-cymem
-                             python-dataclasses
                              python-murmurhash
                              python-numpy
                              python-packaging
                              python-preshed
                              python-pydantic
                              python-srsly
-                             python-typing-extensions
                              python-wasabi))
     (native-inputs (list python-cython python-mock python-pytest))
     (home-page "https://github.com/explosion/thinc")