diff mbox series

[bug#73266,3/9] gnu: Add python-weasel.

Message ID 20240915085720.13323-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#73266,1/9] gnu: Add python-azure-storage-file-datalake. | expand

Commit Message

Nicolas Graves Sept. 15, 2024, 8:57 a.m. UTC
* gnu/packages/python-xyz.scm (python-weasel): New variable.

Change-Id: If9be639d55503ec5dd1c0867708ea63746a5887b
---
 gnu/packages/python-xyz.scm | 47 +++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 42a678ceba..38c877d481 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30718,6 +30718,53 @@  (define-public python-watchgod
 operating systems and an elegant approach to concurrency using threading.")
     (license license:expat)))
 
+(define-public python-weasel
+  (package
+    (name "python-weasel")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "weasel" version))
+       (sha256
+        (base32 "1aas113r29y6yxrmdlsw80rj8w4kgw1jhfjw9rsgc4rf0w7j3g5a"))))
+    (build-system pyproject-build-system)
+    (arguments  ; These tests require network.
+     (list #:test-flags
+           `(list "-k" ,(string-append
+                         "not test_project_git_dir_asset"
+                         " and not test_project_git_file_asset"
+                         " and not test_project_assets"
+                         " and not test_project_clone"
+                         " and not test_remote"))))
+    (propagated-inputs (list python-cloudpathlib
+                             python-confection
+                             python-packaging
+                             python-pydantic
+                             python-requests
+                             python-smart-open
+                             python-srsly
+                             python-typer
+                             python-wasabi))
+    (native-inputs (list git-minimal
+                         python-pytest))
+    (home-page "https://github.com/explosion/weasel")
+    (synopsis "Small workflow system in Python")
+    (description "This package provides management and sharing end-to-end
+workflows for different use cases and domains, and orchestrate training,
+packaging and serving custom pipelines.  It provides the following
+functionality:
+@itemize
+@item clone a pre-defined project template,
+@item adjust it to fit particular needs,
+@item load in data,
+@item train a pipeline,
+@item export it as a Python package,
+@item upload outputs to a remote storage,
+@item share results with a team.
+@end itemize")
+    (license license:expat)))
+
 (define-public python-wget
   (package
     (name "python-wget")