diff mbox series

[bug#73266,2/9] gnu: Add python-cloudpathlib.

Message ID 20240915085720.13323-2-ngraves@ngraves.fr
State New
Headers show
Series [bug#73266,1/9] gnu: Add python-azure-storage-file-datalake. | expand

Commit Message

Nicolas Graves Sept. 15, 2024, 8:57 a.m. UTC
* gnu/packages/python-web.scm (python-cloudpathlib): New variable.

Change-Id: I492abd6bea422faee1b5054edcf8f9e46c286fcf
---
 gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a8510dbcc1..0d0e76e0bd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7569,6 +7569,30 @@  (define-public python-cloud-init
     ;; Either license can be chosen
     (license (list license:asl2.0 license:gpl3))))
 
+(define-public python-cloudpathlib
+  (package
+    (name "python-cloudpathlib")
+    (version "0.19.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cloudpathlib" version))
+       (sha256
+        (base32 "1s2gcv89ybpsvyh6d0rpdpnb177q7la0n8fs4cj5v4sfkbyxp7li"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #f))  ; No tests bundled.
+    (propagated-inputs (list python-azure-storage-blob
+                             python-azure-storage-file-datalake
+                             python-boto3
+                             python-google-cloud-storage
+                             python-typing-extensions))
+    (native-inputs (list python-flit-core))
+    (home-page "https://cloudpathlib.drivendata.org/stable")
+    (synopsis "Python classes for cloud storage services")
+    (description "This package provides provides @code{pathlib.Path}-like
+classes for different cloud storage services.")
+    (license license:expat)))
+
 (define-public python-cloudscraper
   (package
     (name "python-cloudscraper")