diff mbox series

[bug#73266,1/9] gnu: Add python-azure-storage-file-datalake.

Message ID 20240915085720.13323-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#73266,1/9] gnu: Add python-azure-storage-file-datalake. | expand

Commit Message

Nicolas Graves Sept. 15, 2024, 8:57 a.m. UTC
* gnu/packages/python-web.scm (python-azure-storage-file-datalake): New variable.

Change-Id: Iba59fc31822b95361558f1ef62a2a40be0865080
---
 gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8b29f1cd93..a8510dbcc1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8072,6 +8072,28 @@  (define-public python-azure-core
 Python.")
     (license license:expat)))
 
+(define-public python-azure-storage-file-datalake
+  (package
+    (name "python-azure-storage-file-datalake")
+    (version "12.16.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "azure-storage-file-datalake" version))
+       (sha256
+        (base32 "0cq302vpnhb2fwlm6zxhpypqs97gn93cp27vhkpn50a39q75i19i"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-azure-core
+                             python-azure-storage-blob
+                             python-isodate
+                             python-typing-extensions))
+    (home-page "https://github.com/Azure/azure-sdk-for-python")
+    (synopsis "Microsoft Azure File DataLake Storage Client Library for Python")
+    (description
+     "This package provides the Microsoft Azure File @code{DataLake} Storage
+Client Library for Python.")
+    (license license:expat)))
+
 (define-public python-azure-storage-blob
   (package
     (name "python-azure-storage-blob")