diff mbox series

[bug#73203,3/3] gnu: Remove python-msrest.

Message ID 20240912172133.3611-3-ngraves@ngraves.fr
State New
Headers show
Series Fix python-azure packages. | expand

Commit Message

Nicolas Graves Sept. 12, 2024, 5:21 p.m. UTC
* gnu/packages/python-web.scm (python-msrest): Delete variable.

Change-Id: Ic27ba6fe0e7f828327e98c99eabf536ea1cd544a
---
 gnu/packages/python-web.scm | 47 -------------------------------------
 1 file changed, 47 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 03d21f77d7..c51ac642ca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7960,53 +7960,6 @@  (define-public python-siosocks
 @end itemize")
     (license license:expat)))
 
-(define-public python-msrest
-  (package
-    (name "python-msrest")
-    (version "0.6.21")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "msrest" version))
-       (sha256
-        (base32 "1n389m3hcsyjskzimq4j71nyw9pjkrp0n5wg1q2c4bfwpv3inrkj"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest"
-                       "-k"
-                       ;; These attempt to connect to bing.com.
-                       (string-append
-                        "not test_basic_aiohttp"
-                        " and not test_basic_async_requests"
-                        " and not test_conf_async_requests"
-                        " and not test_conf_async_trio_requests"
-                        " and not test_basic_aiohttp"
-                        " and not test_basic_async_requests"
-                        " and not test_conf_async_requests"
-                        " and not test_conf_async_trio_requests"))))))))
-    (propagated-inputs
-     (list python-aiohttp
-           python-certifi
-           python-isodate
-           python-requests
-           python-requests-oauthlib))
-    (native-inputs
-     (list python-httpretty
-           python-pytest
-           python-pytest-aiohttp
-           python-pytest-asyncio
-           python-pytest-trio))
-    (home-page "https://github.com/Azure/msrest-for-python")
-    (synopsis "AutoRest swagger generator Python client runtime")
-    (description "This package provides the runtime library @code{msrest} for
-AutoRest-generated Python clients.")
-    (license license:expat)))
-
 (define-public python-azure-nspkg
   (package
     (name "python-azure-nspkg")