diff mbox series

[bug#73203,1/3] gnu: python-azure-core: Update to 1.28.0.

Message ID 20240912172133.3611-1-ngraves@ngraves.fr
State New
Headers show
Series Fix python-azure packages. | expand

Commit Message

Nicolas Graves Sept. 12, 2024, 5:21 p.m. UTC
* gnu/packages/python-web.scm (python-azure-core): Update to 1.28.0.
[build-system]: Move to pyproject-build-system.
[arguments]<#:test-flags>: Use it.
           <#:phases>: Move from check phase replacement to a lighter
           'add-test-pythonpath pre-check phase.
[propagated-inputs]: Remove python-trio.
[native-inputs]: Remove python-msrest.

Change-Id: Ie4656ddaa1919144cc75a81feecb9ec774c9436f
---
 gnu/packages/python-web.scm | 66 +++++++++++++++----------------------
 1 file changed, 26 insertions(+), 40 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e94d0c44b9..5b75fd06ea 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8069,59 +8069,45 @@  (define-public python-azure-common
 (define-public python-azure-core
   (package
     (name "python-azure-core")
-    (version "1.24.0")
+    (version "1.28.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "azure-core" version ".zip"))
        (sha256
-        (base32 "1r8bpn3zz02mj00qbaks5qq49wqd3mznkm90bchd1mxa3w21nnrl"))))
-    (build-system python-build-system)
+        (base32 "1g9nv5pcjkskv37vsjgsm7am81y629flwkghnvd5dphzzikgrvp9"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               ;; This fails because devtools_testutils doesn't exist.
-               (delete-file "tests/test_connection_string_parsing.py")
-               ;; Needs network.
-               (for-each delete-file
-                         '("tests/async_tests/test_streaming_async.py"
-                           "tests/test_streaming.py"))
-               (add-installed-pythonpath inputs outputs)
-               (setenv "PYTHONPATH"
-                       (string-append (getcwd) "/tests/testserver_tests/coretestserver:"
-                                      (getenv "GUIX_PYTHONPATH")))
-               (invoke "pytest"
-                       ;; Most of these need network access.
-                       "-m" "not asyncio and not live_test_only"
-                       "-k"
-                       ;; These need network access.
-                       (string-append
-                        "not test_example_raw_response_hook"
-                        " and not test_example_headers_policy"
-                        " and not test_example_request_id_policy"
-                        " and not test_example_user_agent_policy"
-                        " and not test_example_requests"
-                        " and not test_example_pipeline"
-                        " and not test_example_pipeline_client"
-                        " and not test_example_redirect_policy"
-                        " and not test_example_no_redirects"
-                        " and not test_example_retry_policy"
-                        " and not test_example_no_retries"
-                        " and not test_decompress_plain_no_header"
-                        " and not test_compress_plain_no_header"
-                        " and not test_decompress_compressed_no_header"))))))))
+     (list
+      #:test-flags
+      `(list ;; This fails because devtools_testutils doesn't exist.
+        "--ignore=tests/test_connection_string_parsing.py"
+        ;; These all need network access.
+        "--ignore=samples"
+        "--ignore=tests/async_tests/test_streaming_async.py"
+        "--ignore=tests/test_streaming.py"
+        "-m" "not asyncio and not live_test_only"
+        "-k" ,(string-append
+               "not test_decompress_plain_no_header"
+               " and not test_compress_plain_no_header"
+               " and not test_decompress_compressed_no_header"
+               " and not test_requests_socket_timeout"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'add-test-pythonpath
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (setenv "PYTHONPATH"
+                        (string-append
+                         (getcwd) "/tests/testserver_tests/coretestserver:"
+                         (getenv "GUIX_PYTHONPATH")))))))))
     (propagated-inputs
      (list python-aiohttp
            python-requests
            python-six
-           python-trio
            python-typing-extensions))
     (native-inputs
      (list python-flask
-           python-msrest
            python-pytest
            python-pytest-aiohttp
            python-pytest-asyncio