diff mbox series

[bug#72982,v2] gnu: genimage: Update to version 18.

Message ID 20240910180414.32509-1-herman@rimm.ee
State New
Headers show
Series [bug#72982,v2] gnu: genimage: Update to version 18. | expand

Commit Message

Herman Rimm Sept. 10, 2024, 6:04 p.m. UTC
* gnu/packages/genimage.scm (genimage): Update from 15 to 18.
[arguments]: Disable some tests.
---
 gnu/packages/genimage.scm | 62 +++++++++++++++++++++++----------------
 1 file changed, 36 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index 13f3dd67b0..b90adffb67 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -41,27 +41,26 @@  (define-module (gnu packages genimage)
   #:use-module (gnu packages virtualization))
 
 (define-public genimage
-  (let ((commit "ec44ae086c705e6f0439e742c5a2e9b8f3d6ca82")
-        (revision "1"))
+  (let ((commit "00009af6e29cfd46909bc8b4180147dda9f82ba8")
+        (revision "0"))
     (package
       (name "genimage")
-      (version (git-version "15" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/pengutronix/genimage")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0amj2vjff58yna6kq959i2gqmbjywqr8j5kr5pjqsvbqam3vgg0r"))
-                (patches
-                 (search-patches "genimage-mke2fs-test.patch"))))
+      (version (git-version "18" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/pengutronix/genimage")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "1mijyq79cb0yj4jm9ln9smpddq1f6r8cnsa568qca0krcv0p3zag"))))
       (build-system gnu-build-system)
       (arguments
        `(#:modules
          ((ice-9 match)
-          ,@%default-gnu-modules)
+          ,@%gnu-build-system-modules)
          #:phases
          (modify-phases %standard-phases
            (add-after 'unpack 'guixify
@@ -70,8 +69,8 @@  (define-public genimage
                       ((input directory regexp)
                        (substitute* "config.c"
                          (((format #f "\\.def = \"(~a)\"" regexp) _ command)
-                          (format #f ".def = \"~a/~a/~a\""
-                                  (assoc-ref inputs input) directory command)))))
+                          (string-append ".def = \"" (assoc-ref inputs input)
+                                         "/" directory "/" command "\"")))))
                     '(("cpio"           "bin"  "cpio")
                       ("coreutils"      "bin"  "dd")
                       ("e2fsprogs"      "sbin" "debugfs|e2fsck|mke2fs|tune2fs")
@@ -81,26 +80,36 @@  (define-public genimage
                       ;; mkcramfs is obsolete.
                       ("dosfstools"     "sbin" "mkdosfs")
                       ("mtd-utils"      "sbin" "mkfs.(jffs2|ubifs)|ubinize")
+                      ("f2fs-tools"     "sbin" "(mkfs|sload).f2fs")
                       ("squashfs-tools" "bin"  "mksquashfs")
                       ("qemu"           "bin"  "qemu-img")
+                      ;; rauc and fiptool are unsupported.
                       ("tar"            "bin"  "tar")
                       ("u-boot-tools"   "bin"  "mkimage")))
                (substitute* "util.c"
                  (("\"/bin/sh\"")
                   (string-append "\"" (assoc-ref inputs "bash") "/bin/sh\"")))))
+           (add-before 'check 'disable-failing-tests
+             (lambda _
+               ;; We don't have /etc/passwd so uid 0 is not known as "root".
+               ;; Thus patch it out.
+               (substitute* '("test/flash.test")
+                 (("test_expect_success \"flash\"")
+                  "test_expect_fail \"flash\""))
+               (substitute* '("test/hdimage.test")
+                 (("test_expect_success fdisk,sfdisk \"hdimage\"")
+                  "test_expect_fail fdisk,sfdisk \"hdimage\"")
+                 (("test_expect_success hexdump \"hdimage no-partition\"")
+                  "test_expect_fail hexdump \"hdimage no-partition\""))))
            (add-before 'check 'fix-failing-tests
              (lambda _
                ;; We don't have /etc/passwd so uid 0 is not known as "root".
                ;; Thus patch it out.
-               (substitute* '("test/ext2test.0.dump"
-                              "test/ext2test.1.dump"
-                              "test/ext3test.0.dump"
-                              "test/ext3test.1.dump"
-                              "test/ext4test.0.dump"
-                              "test/ext4test.1.dump"
-                              "test/ext2test-percent.0.dump"
-                              "test/ext2test-percent.1.dump"
-                              "test/mke2fs.0.dump")
+               (substitute* '("test/ext2test.2.dump"
+                              "test/ext3test.2.dump"
+                              "test/ext4test.2.dump"
+                              "test/ext2test-percent.2.dump"
+                              "test/mke2fs.2.dump")
                  (("root") "unknown"))))
            (add-before 'check 'setenv-check
              (lambda _
@@ -127,6 +136,7 @@  (define-public genimage
          ("coreutils" ,coreutils) ; chmod, dd
          ("dosfstools" ,dosfstools)
          ("e2fsprogs" ,e2fsprogs)
+         ("f2fs-tools" ,f2fs-tools)
          ("genext2fs" ,genext2fs)
          ("libconfuse" ,libconfuse)
          ("mtd-utils" ,mtd-utils)