diff mbox series

[bug#73168] gnu: bash-minimal: Add package description.

Message ID 20240910141719.30059-1-romain.garbage@inria.fr
State New
Headers show
Series [bug#73168] gnu: bash-minimal: Add package description. | expand

Commit Message

Romain GARBAGE Sept. 10, 2024, 2:13 p.m. UTC
* gnu/packages/bash.scm (bash-minimal): Add package description.

Change-Id: I37da88d189f3a2d99aa8bcba5de3102909ae4761
---
 gnu/packages/bash.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)


base-commit: 7f05b73d90f740c6a139f0e706b717d3174f6321

Comments

jgart Sept. 10, 2024, 4:22 p.m. UTC | #1
Hi,

This should go to core-updates.
Ludovic Courtès Sept. 12, 2024, 10:47 a.m. UTC | #2
Hi Romain,

Romain GARBAGE <romain.garbage@inria.fr> skribis:

> * gnu/packages/bash.scm (bash-minimal): Add package description.
>
> Change-Id: I37da88d189f3a2d99aa8bcba5de3102909ae4761

[...]

> +    (description "This is a stripped-down version of the @code{bash} package for
> +non-interactive use.")))

Good initiative.  I would change the synopsis rather than the
description (this is what’s usually/often done for package variants),
like, say:

  (synopsis "The GNU Bourne-Again SHell, stripped down for non-interactive use")

WDYT?

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 9ecec0a484..ad94c076bf 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -258,7 +258,9 @@  (define-public bash-minimal
        ((#:phases phases)
         `(modify-phases ,phases
            ;; No loadable modules.
-           (delete 'move-development-files)))))))
+           (delete 'move-development-files)))))
+    (description "This is a stripped-down version of the @code{bash} package for
+non-interactive use.")))
 
 (define-public static-bash
   ;; Statically-linked Bash that contains nothing but the 'bash' binary and