diff mbox series

[bug#73154] gnu: rust: update to 1.81

Message ID 20240909182356.2221764-1-brennan@umanwizard.com
State New
Headers show
Series [bug#73154] gnu: rust: update to 1.81 | expand

Commit Message

Brennan Vincent Sept. 9, 2024, 6:23 p.m. UTC
From: Brennan Vincent <brennan@umanwizard.com>

gnu/packages/rust.scm (new variable): rust-1.81.
gnu/packages/rust.scm (rust): update to 1.81.

Change-Id: Idb1958364225bebb9aa415419083b6ab97d7c4c7
---
 gnu/packages/rust.scm | 20 +++++++++++++++++---
 1 file changed, 17 insertions(+), 3 deletions(-)

Comments

Brennan Vincent Sept. 9, 2024, 6:27 p.m. UTC | #1
Please note that this patch depends on my previous series of patches to
upgrade Rust to 1.80.

https://lists.gnu.org/archive/html/guix-patches/2024-08/msg01076.html

help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 73154@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> -- 
> 73154: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=73154
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
Maxim Cournoyer Sept. 10, 2024, 5:46 a.m. UTC | #2
block 73154 by 72327
quit

Hi,

"Brennan Vincent" <brennan@umanwizard.com> writes:

> Please note that this patch depends on my previous series of patches to
> upgrade Rust to 1.80.

Expressing this in the tracker by blocking bug #73154 with bug #72327
with the above commands (and CC'ing the control server).
Efraim Flashner Sept. 17, 2024, 9:56 a.m. UTC | #3
Thanks. Patch pushed to the rust-team branch.
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 396e8a858a..a33399d8fc 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1050,6 +1050,12 @@  (define-public rust-1.80
                (("features = \\[\"fs\"" all)
                 (string-append all ", \"use-libc\""))))))))))
 
+(define-public rust-1.81
+  (let ((base-rust (rust-bootstrapped-package rust-1.80 "1.81.0"
+                                              "19yggj1qivdhf68gx2652cfi7nxjkdgy39wh7h6facpzppz4h947")))
+    (package
+      (inherit base-rust))))
+
 (define (make-ignore-test-list strs)
   "Function to make creating a list to ignore tests a bit easier."
   (map (lambda (str)
@@ -1064,7 +1070,7 @@  (define (make-ignore-test-list strs)
 ;;; Here we take the latest included Rust, make it public, and re-enable tests
 ;;; and extra components such as rustfmt.
 (define-public rust
-  (let ((base-rust rust-1.80))
+  (let ((base-rust rust-1.81))
     (package
       (inherit base-rust)
       (properties (append
@@ -1134,7 +1140,10 @@  (define-public rust
                       '("fn fetch_downloads_with_git2_first_")))
                  (substitute* "src/tools/cargo/tests/testsuite/build.rs"
                    ,@(make-ignore-test-list
-                      '("fn build_with_symlink_to_path_dependency_with_build_script_in_git")))))
+                      '("fn build_with_symlink_to_path_dependency_with_build_script_in_git")))
+                 (substitute* "src/tools/cargo/tests/testsuite/publish_lockfile.rs"
+                   ,@(make-ignore-test-list
+                      '("fn note_resolve_changes")))))
              (add-after 'unpack 'disable-tests-requiring-mercurial
                (lambda _
                  (with-directory-excursion "src/tools/cargo/tests/testsuite/cargo_init"
@@ -1222,7 +1231,12 @@  (define-public rust
                    ;; string "rustc"
                    ,@(make-ignore-test-list
                       '("fn config_fingerprint"
-                        "fn features_fingerprint")))))
+                        "fn features_fingerprint")))
+                 (substitute* "src/tools/cargo/tests/testsuite/git_auth.rs"
+                   ;; This checks for a specific networking error message
+                   ;; that's different from the one we see in the builder
+                   ,@(make-ignore-test-list
+                      '("fn net_err_suggests_fetch_with_cli")))))
              (add-after 'unpack 'patch-command-exec-tests
                ;; This test suite includes some tests that the stdlib's
                ;; `Command` execution properly handles in situations where