diff mbox series

[bug#73152,5/6] gnu: nss-rapid: Update to 3.104.

Message ID 20240909175540.8156-6-ian@retrospec.tv
State New
Headers show
Series [bug#73152,1/6] gnu: Remove nss/fixed. | expand

Commit Message

Ian Eure Sept. 9, 2024, 5:55 p.m. UTC
* gnu/packages/nss.scm (nss-rapid): Update to 3.104.

Change-Id: I22772d75a98a479a65717ea7bcbfbb7986bd0c77
---
 gnu/packages/nss.scm | 67 ++++++++------------------------------------
 1 file changed, 11 insertions(+), 56 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index b4fdd13abc..b53e6e22cf 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -281,63 +281,18 @@  (define-public nss
 ;; and https://wiki.mozilla.org/Rapid_Release_Model
 
 (define-public nss-rapid
-  (package
-   (inherit nss)
-   (name "nss-rapid")
-   (version "3.103")
-   (source (origin
-             (inherit (package-source nss))
-             (uri (let ((version-with-underscores
-                         (string-join (string-split version #\.) "_")))
-                    (string-append
-                     "https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
-                     "releases/NSS_" version-with-underscores "_RTM/src/"
-                     "nss-" version ".tar.gz")))
-             (sha256
-              (base32
-               "0qp9rs226rr6gh51b42cdbydr4mj80cli3bfqhh7bp3jyxbvcjkv"))))
-   (arguments
-    (substitute-keyword-arguments (package-arguments nss)
-      ((#:phases phases)
-       #~(modify-phases #$phases
-           (replace 'check
-             (lambda* (#:key tests? #:allow-other-keys)
-               (if tests?
-                   (begin
-                     ;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for
-                     ;; testing.  The latter requires a working DNS or /etc/hosts.
-                     (setenv "DOMSUF" "localdomain")
-                     (setenv "USE_IP" "TRUE")
-                     (setenv "IP_ADDRESS" "127.0.0.1")
-
-                     ;; This specific test is looking at performance "now
-                     ;; verify that we can quickly dump a database", and
-                     ;; we're not testing performance here (especially
-                     ;; since we're using faketime), so raise the
-                     ;; threshold
-                     (substitute* "nss/tests/dbtests/dbtests.sh"
-                       ((" -lt 5") " -lt 50"))
-
-                     ;; Since the test suite is very lengthy, run the test
-                     ;; suite once, not thrice as done by default, by
-                     ;; selecting only the 'standard' cycle.
-                     (setenv "NSS_CYCLES" "standard")
-
-                     ;; The "PayPalEE.cert" certificate expires every six months,
-                     ;; leading to test failures:
-                     ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To
-                     ;; work around that, set the time to roughly the release date.
-                     (invoke "faketime" "2024-08-17" "./nss/tests/all.sh"))
-                   (format #t "test suite not run~%"))))))))
-   (synopsis "Network Security Services (Rapid Release)")
-   (description
-    "Network Security Services (@dfn{NSS}) is a set of libraries designed to
-support cross-platform development of security-enabled client and server
-applications.  Applications built with NSS can support SSL v2 and v3, TLS,
-PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other
-security standards.
+  (let ((base (make-nss
+               #:version "3.104"
+               #:release-date "2024-08-30"
+               #:hash "13mca2y92sm05kxb40qvlkq8l93ghmrhh0s3iawpc7idc8ik4xp2")))
+    (package
+      (inherit base)
+      (name (string-append (package-name base) "-rapid"))
+      (synopsis (string-append (package-synopsis base) " (Rapid Release)"))
+      (description
+       (string-append (package-description base) "
+This package tracks the Rapid Release channel, which updates frequently.")))))
 
-This package tracks the Rapid Release channel, which updates frequently.")))
 (define-public nsncd
   (package
     (name "nsncd")