diff mbox series

[bug#73109,1/2] gnu: python-huggingface-hub: Update to 0.23.2.

Message ID 20240907165703.23229-1-ngraves@ngraves.fr
State New
Headers show
Series Add python-transformers | expand

Commit Message

Nicolas Graves Sept. 7, 2024, 4:56 p.m. UTC
* gnu/packages/python-web.scm (python-huggingface-hub): Update to 0.23.2.

Change-Id: I06989e883f54d9f0fc8db002d0a580008f6c6b67
---
 gnu/packages/python-web.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bb1b912c0c..2a7dc8f8b3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -143,7 +143,7 @@  (define-module (gnu packages python-web)
 (define-public python-huggingface-hub
   (package
     (name "python-huggingface-hub")
-    (version "0.20.3")
+    (version "0.23.2")
     (source
      (origin
        (method git-fetch)
@@ -152,7 +152,7 @@  (define-public python-huggingface-hub
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "00indl9labvqvm4m0y5jbzl68cgj8i60a6qy498gpnjj2pqk4l6v"))))
+        (base32 "0hygxqcixkc1d9sr47j2km6z0p17aj4k1dzm4cvpddrvhrgqayq5"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -185,7 +185,11 @@  (define-public python-huggingface-hub
              "--ignore=tests/test_utils_git_credentials.py"
              "--ignore=tests/test_utils_http.py"
              "--ignore=tests/test_utils_pagination.py"
-             "--ignore=tests/test_webhooks_server.py")
+             "--ignore=tests/test_webhooks_server.py"
+             "-k" (string-append
+                   "not test_push_to_hub"
+                   " and not test_from_pretrained_model_id_only"
+                   " and not test_from_pretrained_model_id_and_revision"))
       #:phases
       '(modify-phases %standard-phases
          (add-before 'check 'pre-check