diff mbox series

[bug#71782,v5,1/4] gnu: Add go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel.

Message ID 20240905231707.5908-1-nandre@riseup.net
State New
Headers show
Series Update torbrowser and mullvadbrowser to v. 13.5.3. | expand

Commit Message

André Batista Sept. 5, 2024, 11:17 p.m. UTC
* gnu/packages/golang.scm
  (go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel):
  New variable.

Change-Id: I84ef723ea03822bd5abf655914f44fb53fd865e2
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f04b8e423..af2acc909e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2241,6 +2241,31 @@  (define-public go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports
 incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.")
     (license (list license:bsd-2 license:bsd-3))))
 
+(define-public go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel
+  (let ((commit "e64b1b3562f3ab50d06141ecd513a21ec74fe8c6")
+        (revision "0"))
+    (package
+      (name "go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/webtunnel")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0nvd0qp1mdy7w32arnkhghxm5k2g6gy33cxlarxc6vdm4yh6v5nv"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/webtunnel"))
+      (home-page "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/webtunnel")
+      (synopsis "Go WebTunnel Pluggable Transport")
+      (description "WebTunnel is a Go Pluggable Transport that attempts to imitate
+web browsing activities based on HTTP Upgrade (HTTPT).")
+      (license license:bsd-2))))
+
 (define-public go-github-com-sevlyar-go-daemon
   (package
     (name "go-github-com-sevlyar-go-daemon")