[bug#72963,go-team,09/30] gnu: Add go-github-com-shurcool-githubv4.

Message ID 20240902121843.31430-8-herman@rimm.ee
State New
Headers
Series None |

Commit Message

Herman Rimm Sept. 2, 2024, 12:18 p.m. UTC
  * gnu/packages/golang-web.scm (go-github-com-shurcool-githubv4): Add
variable.
---
 gnu/packages/golang-web.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 833d2b5a94..be1d82cefa 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3233,6 +3233,31 @@  (define-public go-github-com-sherclockholmes-webpush-go
 support.")
     (license license:expat)))
 
+(define-public go-github-com-shurcool-githubv4
+  (package
+    (name "go-github-com-shurcool-githubv4")
+    (version "0.0.0-20240429030203-be2daab69064")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/shurcooL/githubv4")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0kkvqwv0waa8hj1jr9b4nvz8rmslqpchidl7gs9bplrkl3fvsxn6"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/shurcooL/githubv4"))
+    (inputs (list go-golang-org-x-oauth2))
+    (propagated-inputs (list go-github-com-shurcool-graphql))
+    (home-page "https://github.com/shurcooL/githubv4")
+    (synopsis "Client library for GitHub GraphQL API v4")
+    (description
+     "Package githubv4 is a client library for accessing GitHub
+@code{GraphQL} API v4.")
+    (license license:expat)))
+
 (define-public go-github-com-sourcegraph-jsonrpc2
   (package
     (name "go-github-com-sourcegraph-jsonrpc2")