[bug#72963,go-team,08/30] gnu: Add go-github-com-shurcool-graphql.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-shurcool-graphql): Add
variable.
---
gnu/packages/golang-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -5264,6 +5264,28 @@ (define-public go-github-com-shirou-gopsutil-v3
;; environment.
(string-append "src/" import-path "/host/host_test.go")))))))))
+(define-public go-github-com-shurcool-graphql
+ (package
+ (name "go-github-com-shurcool-graphql")
+ (version "0.0.0-20230722043721-ed46e5a46466")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/graphql")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12cq16qak217bkpklqsmqhl42gz8cpadpzqw6fsivc3ambjpqdry"))))
+ (build-system go-build-system)
+ (arguments (list #:import-path "github.com/shurcooL/graphql"))
+ (home-page "https://github.com/shurcooL/graphql")
+ (synopsis "GraphQL client")
+ (description
+ "Package graphql provides a @code{GraphQL} client implementation.")
+ (license license:expat)))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")