[bug#72963,go-team,08/30] gnu: Add go-github-com-shurcool-graphql.

Message ID 20240902121843.31430-7-herman@rimm.ee
State New
Headers
Series None |

Commit Message

Herman Rimm Sept. 2, 2024, 12:18 p.m. UTC
  * gnu/packages/golang-xyz.scm (go-github-com-shurcool-graphql): Add
variable.
---
 gnu/packages/golang-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9c13c3c61b..afb8dbaa7a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5264,6 +5264,28 @@  (define-public go-github-com-shirou-gopsutil-v3
                ;; environment.
                (string-append "src/" import-path "/host/host_test.go")))))))))
 
+(define-public go-github-com-shurcool-graphql
+  (package
+    (name "go-github-com-shurcool-graphql")
+    (version "0.0.0-20230722043721-ed46e5a46466")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/shurcooL/graphql")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "12cq16qak217bkpklqsmqhl42gz8cpadpzqw6fsivc3ambjpqdry"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/shurcooL/graphql"))
+    (home-page "https://github.com/shurcooL/graphql")
+    (synopsis "GraphQL client")
+    (description
+     "Package graphql provides a @code{GraphQL} client implementation.")
+    (license license:expat)))
+
 (define-public go-github-com-skip2-go-qrcode
   (package
     (name "go-github-com-skip2-go-qrcode")