[bug#72963,go-team,14/30] gnu: Add go-github-com-kylelemons-godebug-pretty.

Message ID 20240902121843.31430-13-herman@rimm.ee
State New
Headers
Series None |

Commit Message

Herman Rimm Sept. 2, 2024, 12:18 p.m. UTC
  * gnu/packages/golang.scm (go-github-com-kylelemons-godebug-pretty): Add
variable.
---
 gnu/packages/golang.scm | 8 ++++++++
 1 file changed, 8 insertions(+)
  

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c776f78609..be885d90ca 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4972,6 +4972,14 @@  (define-public go-github-com-kylelemons-godebug
 representation suitable for computing diffs.")
     (license license:asl2.0)))
 
+(define-public go-github-com-kylelemons-godebug-pretty
+  (package
+    (inherit go-github-com-kylelemons-godebug)
+    (name "go-github-com-kylelemons-godebug-pretty")
+    (arguments
+      (list #:import-path "github.com/kylelemons/godebug/pretty"
+            #:unpack-path "github.com/kylelemons/godebug"))))
+
 (define-public go-github-com-kr-text
   (package
     (name "go-github-com-kr-text")