[bug#72963,go-team,13/30] gnu: Add go-gopkg-in-dnaeon-go-vcr-v3-recorder.

Message ID 20240902121843.31430-12-herman@rimm.ee
State New
Headers
Series None |

Commit Message

Herman Rimm Sept. 2, 2024, 12:18 p.m. UTC
  * gnu/packages/golang-check.scm (go-gopkg-in-dnaeon-go-vcr-v3-recorder):
Add variable.
---
 gnu/packages/golang-check.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 733fe89699..acf7ebb53d 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1179,6 +1179,33 @@  (define-public go-gopkg-in-check-v1
     (description "This package provides a test library for the Go language.")
     (license license:bsd-2)))
 
+(define-public go-gopkg-in-dnaeon-go-vcr-v3-recorder
+  (package
+    (name "go-gopkg-in-dnaeon-go-vcr-v3-recorder")
+    (version "3.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gopkg.in/dnaeon/go-vcr.v3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1nij7rjbnrbsgjlm7fwpg298qffrgi2ic3wb51vqzxl6s9qkbzrq"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "gopkg.in/dnaeon/go-vcr.v3/recorder"
+           #:unpack-path "gopkg.in/dnaeon/go-vcr.v3"))
+    (propagated-inputs (list go-gopkg-in-yaml-v3))
+    (home-page "https://gopkg.in/dnaeon/go-vcr.v3")
+    (synopsis "Record and replay your HTTP interactions")
+    (description
+     "@@code{go-vcr} simplifies testing by recording your HTTP
+interactions and replaying them in future runs in order to provide fast,
+deterministic and accurate testing of your code.")
+    (license license:bsd-2)))
+
 (define-public go-gopkg-in-go-playground-assert-v1
   (package
     (name "go-gopkg-in-go-playground-assert-v1")