[bug#72963,go-team,12/30] gnu: Add go-go-abhg-dev-requiredfield.

Message ID 20240902121843.31430-11-herman@rimm.ee
State New
Headers
Series None |

Commit Message

Herman Rimm Sept. 2, 2024, 12:18 p.m. UTC
  * gnu/packages/golang-check.scm (go-go-abhg-dev-requiredfield): Add
variable.
---
 gnu/packages/golang-check.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 287a514ace..733fe89699 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1033,6 +1033,30 @@  (define-public go-github.com-smartystreets-gunit
 under test) much simpler.")
     (license license:expat)))
 
+(define-public go-go-abhg-dev-requiredfield
+  (package
+    (name "go-go-abhg-dev-requiredfield")
+    (version "0.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/abhinav/requiredfield")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+          "15dccs71is06wi8xi3y2nnwpcpqbsh4pas4iggdr514aix8ljknf"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "go.abhg.dev/requiredfield"))
+    (propagated-inputs (list go-golang-org-x-tools))
+    (home-page "https://go.abhg.dev/requiredfield")
+    (synopsis "Linter for required struct fields")
+    (description
+     "Package requiredfield implements a linter that checks for required
+fields during struct initialization.")
+    (license license:bsd-3)))
+
 (define-public go-go-etcd-io-gofail
   (package
     (name "go-go-etcd-io-gofail")