[bug#72963,go-team,02/30] gnu: Add go-github-com-sebdah-goldie-v2.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-sebdah-goldie-v2): Add
variable.
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -5038,6 +5038,32 @@ (define-public go-github-com-schollz-progressbar-v3
is undetermined, a customizable spinner is shown.")
(license license:expat)))
+(define-public go-github-com-sebdah-goldie-v2
+ (package
+ (name "go-github-com-sebdah-goldie-v2")
+ (version "2.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sebdah/goldie")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12gji9p6b6zlkisbd3ww103zwd5chlwkb6h5dppfrmgxim84n5n0"))))
+ (build-system go-build-system)
+ (arguments (list #:import-path "github.com/sebdah/goldie/v2"))
+ (propagated-inputs (list go-github-com-stretchr-testify
+ go-github-com-sergi-go-diff
+ go-github-com-pmezard-go-difflib))
+ (home-page "https://github.com/sebdah/goldie")
+ (synopsis "Golden test utility")
+ (description
+ "Package goldie provides test assertions based on golden files.
+It's typically used for testing responses with larger data bodies.")
+ (license license:expat)))
+
(define-public go-github-com-sergi-go-diff
(package
(name "go-github-com-sergi-go-diff")