[bug#72963,go-team,01/30] gnu: Add go-github-com-buildkite-shellwords.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-buildkite-shellwords): Add
variable.
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Comments
Hi,
Thank you for the patches.
I started reviewing them.
--
Oleg
Hi,
I've update git-spice to the latest version and pack missing packages.
Some of the proposed ones were already present so they were skipped.
go-inputs procedure is not required as new "go import go <package>"
respect subdirs of the workspace in Golang project which are tagged
individually.
Adjust all commit messages from "Add variable" to "New variable".
Adjust some package names to follow go.mod import path style.
In git-spice utilize #:test-flags and "-skip" option to ignore some
failing tests intead of deleting test
- Add [12/12]
- [X] version-control git-spice. Updte to the latest version, add missing inputs.
- [X] golang-check go-go-abhg-dev-requiredfield
- [X] golang-check go-gopkg-in-dnaeon-go-vcr-v3-recorder -> go-gopkg-in-dnaeon-go-vcr-v3
- [X] golang-web go-github-com-shurcool-graphql
- [X] golang-web go-github-com-shurcool-githubv4
- [X] golang-xyz go-github-com-buildkite-shellwords
- [X] golang-xyz go-github-com-charmbracelet-log
- [X] golang-xyz go-github-com-charmbracelet-x-input use #:subdir
- [X] golang-xyz go-github-com-charmbracelet-x-windows use #:subdir
- [X] golang-xyz go-github-com-erikgeiser-coninput
- [X] golang-xyz go-github-com-sebdah-goldie-v2
- [X] golang-xyz go-github-com-vito-midterm
- Skip [9/9]
- [X] duplicate go-github-com-creack-pty-v2
- [X] duplicate go-github-com-charmbracelet-x-ansi
- [X] duplicate go-github-com-charmbracelet-lipgloss
- [X] duplicate go-github-com-charmbracelet-bubbles
- [X] duplicate go-github-com-charmbracelet-x-term
- [X] duplicate go-github-com-rogpeppe-go-internal-testscript
- [X] drop go-inputs procedure.
- [X] drop go-github-com-mattn-go-localereader
- [X] drop Add go-inputs procedure.
Pused to go-team branch.
--
Oleg
@@ -1269,6 +1269,30 @@ (define-public go-github-com-briandowns-spinner
indicator to any terminal application.")
(license license:asl2.0)))
+(define-public go-github-com-buildkite-shellwords
+ (package
+ (name "go-github-com-buildkite-shellwords")
+ (version "0.0.0-20180315110454-59467a9b8e10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/buildkite/shellwords")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kx6wxbdznarmnifwzmxxcd86bgn27rwpfnw2y2gd0j8zg9g1682"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/buildkite/shellwords"))
+ (home-page "https://github.com/buildkite/shellwords")
+ (synopsis "Split command-line strings into words")
+ (description
+ "This package provides a golang library for splitting command-line
+strings into words like a POSIX or Windows shell would.")
+ (license license:expat)))
+
(define-public go-github-com-burntsushi-toml
(package
(name "go-github-com-burntsushi-toml")