diff mbox series

[bug#72873,3/4] gnu: scilab: Fix the scilab build script.

Message ID 20240829162554.28746-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#72873,1/4] gnu: scilab: Update to 2024.1.0. | expand

Commit Message

Nicolas Graves Aug. 29, 2024, 4:25 p.m. UTC
* gnu/packages/maths.scm (scilab):
[arguments]<#:phases>: Reintroduce a manual patch for /bin/ls in phase
pre-build. This is necessary because the file is used when scilab
builds macros, even if it is discarded later.
[inputs]: Add coreutils-minimal.

Change-Id: I692fd6696273bfdce0e50b0f688a60e7dc289ce6
---
 gnu/packages/maths.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a211121375..48a22bb6a1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9907,6 +9907,7 @@  (define-public scilab
            autoconf-archive
            automake
            bison
+           coreutils-minimal
            eigen
            flex
            gfortran
@@ -10014,6 +10015,10 @@  (define-public scilab
                     (("PROGNAME.*") "\n")))))
             (add-before 'build 'pre-build
               (lambda* (#:key inputs #:allow-other-keys)
+                ;; Fix scilab script.
+                (substitute* "bin/scilab"
+                  (("/bin/ls")
+                   (search-input-file inputs "bin/ls")))
                 ;; Fix core.start.
                 (substitute* "modules/core/etc/core.start"
                   (("'SCI/modules")