diff mbox series

[bug#72838,core-updates] gnu: ffmpeg: Fix build on i686 with binutils 2.41.

Message ID 20240827184626.1392-1-nandre@riseup.net
State New
Headers show
Series [bug#72838,core-updates] gnu: ffmpeg: Fix build on i686 with binutils 2.41. | expand

Commit Message

André Batista Aug. 27, 2024, 6:46 p.m. UTC
* gnu/packages/video.scm (ffmpeg): Add 'bypass-openal-check phase
which breaks configure phase on i686. Unconditionally set openal
configure check to true.
---
 gnu/packages/video.scm | 9 +++++++++
 1 file changed, 9 insertions(+)


base-commit: 87cc46aefce0072dc83e667d85a59a34eecfd89f
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f7d58ab8f5..e2720628bb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1835,6 +1835,15 @@  (define-public ffmpeg
          "--disable-mipsfpu")
       #:phases
       #~(modify-phases %standard-phases
+          (add-before 'configure 'bypass-openal-check
+            ;; configure fails linking to openal when using binutils >= 2.38
+            ;; due to openal's usage of protected visibility for its dynamic
+            ;; symbols. Bypass this configure time check for now. See:
+            ;; https://lists.gnu.org/archive/html/guix-devel/2024-08/msg00159.html
+            (lambda _
+              (substitute* "configure"
+                (("alGetError \\|\\|")
+                 "alGetError \|\| true \|\|"))))
           (replace 'configure
             ;; configure does not work followed by "SHELL=..." and
             ;; "CONFIG_SHELL=..."; set environment variables instead