[bug#72746] gnu: Add pantheon-photos.
Commit Message
* gnu/packages/pantheon.scm (pantheon-photos): New variable.
Change-Id: Iaa9fb285faf58425c74abbe73371b777a49caac4
---
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux.
aarch64 is currently failing because of a dependency.
gnu/packages/pantheon.scm | 62 +++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)
Comments
Hi, thanks for the patch.
Pushed with modern g-expression style.
@@ -25,12 +25,15 @@ (define-module (gnu packages pantheon)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages package-management)
#:use-module (gnu packages pcre)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages xml)
#:use-module (gnu packages web)
#:use-module (gnu packages xorg)
@@ -133,6 +136,65 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-photos
+ (package
+ (name "pantheon-photos")
+ (version "8.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/photos")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z3b582y093x6pb3bl7zs4w97vg88rflyhwxfaycxw0rv8pcshhi"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-schema-cache-generation
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.photos"))
+ (link (string-append out "/bin/pantheon-photos")))
+ (symlink bin link)))))))
+ (native-inputs (list desktop-file-utils
+ `(,glib "bin")
+ intltool
+ pkg-config
+ python ;copied from Nix
+ vala))
+ (inputs (list geocode-glib
+ gexiv2
+ granite-6
+ gst-plugins-bad ;copied from Nix
+ gst-plugins-base
+ gst-plugins-good ;copied from Nix
+ gst-plugins-ugly ;copied from Nix
+ gstreamer
+ gtk+
+ libexif
+ libgee
+ libgphoto2
+ libgudev
+ libhandy
+ libportal
+ libraw
+ libwebp
+ sqlite))
+ (synopsis "Photo viewer and organizer designed for the Pantheon desktop")
+ (description
+ "Photos is an image viewer and organizer. It originally comes
+from elementary OS and is designed for the Pantheon desktop environment (but can
+also be used on others.")
+ (home-page "https://elementary.io/open-source")
+ (license license:lgpl2.1+)))
+
(define-public pantheon-terminal
(package
(name "pantheon-terminal")